
        <!doctype html>
        <html lang="en">
            <head>
                <!-- ABCOTV | 7b8e9cbe589f | 21 | ea673e8fb294d1f33e651d8e9189091809f3d98e | Sun, 08 Sep 2019 03:48:49 GMT -->
                <title data-react-helmet="true">Crime Fighters: Who killed Roger David? | 6abc.com</title>
                <meta data-react-helmet="true" name="description" content="A man leaving a club in West Philadelphia is shot and left for dead.  Now his cousin traveled from North Carolina to plea for help in finding his killer."/><meta data-react-helmet="true" name="keywords" content="philadelphia news, west philadelphia, crime fighters, west philadelphia shooting, west philadelphia murder, roger david murder"/><meta data-react-helmet="true" name="apple-itunes-app" content="app-id=405616387, affiliate-data=ct=wpvi-smart-banner&amp;pt=302756, app-argument=https://6abc.com/story/5515451"/><meta data-react-helmet="true" property="fb:app_id" content="2022478634557698"/><meta data-react-helmet="true" property="fb:pages" content="9335481377"/><meta data-react-helmet="true" property="og:site_name" content="6abc Philadelphia"/><meta data-react-helmet="true" property="og:url" content="https://6abc.com/5515451/"/><meta data-react-helmet="true" property="og:title" content="Crime Fighters: Who killed Roger David?"/><meta data-react-helmet="true" property="og:description" content="A man leaving a club in West Philadelphia is shot and left for dead.  Now his cousin traveled from North Carolina to plea for help in finding his killer."/><meta data-react-helmet="true" property="og:image" content="https://cdn.abcotvs.com/dip/images/5522984_090719-wpvi-crime-fighters-10pm-video-vid.jpg?w=1600"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" name="twitter:site" content="@6abc"/><meta data-react-helmet="true" name="twitter:creator" content="@6abc"/><meta data-react-helmet="true" name="twitter:url" content="https://6abc.com/5515451/"/><meta data-react-helmet="true" name="twitter:title" content="Crime Fighters: Who killed Roger David?"/><meta data-react-helmet="true" name="twitter:description" content="A man leaving a club in West Philadelphia is shot and left for dead.  Now his cousin traveled from North Carolina to plea for help in finding his killer."/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:image" content="https://cdn.abcotvs.com/dip/images/5522984_090719-wpvi-crime-fighters-10pm-video-vid.jpg?w=1600"/><meta data-react-helmet="true" name="twitter:app:name:iphone" content="wpvi"/><meta data-react-helmet="true" name="twitter:app:id:iphone" content="405616387"/><meta data-react-helmet="true" name="twitter:app:name:googleplay" content="wpvi"/><meta data-react-helmet="true" name="twitter:app:id:googleplay" content="com.abclocal.wpvi.news"/><meta data-react-helmet="true" property="article:published_time" content="2019-09-08T03:07:00.000Z"/><meta data-react-helmet="true" property="article:modified_time" content="2019-09-08T03:07:00.000Z"/><meta data-react-helmet="true" property="article:section" content="crime-safety"/><meta data-react-helmet="true" name="title" content="Crime Fighters: Who killed Roger David?"/><meta data-react-helmet="true" name="medium" content="website"/>

                <meta charSet="utf-8" />
                <meta name="viewport" content="initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
                <meta http-equiv="x-ua-compatible" content="IE=edge,chrome=1" />
                <meta name="robots" content="NOODP,NOYDIR" />
                <meta property="og:locale" content="en_US" />
                <link href="//d32rtoyz6r06ud.cloudfront.net" rel="preconnect" />
                <link href="https://cdn.abcotvs.net/abcotv" rel="preconnect" crossorigin />
                <link rel="stylesheet" href="//d32rtoyz6r06ud.cloudfront.net/abcotv/ea673e8fb294-hotfix-dtcinews7.0/client/css/abcotv.css" />
                <link data-react-helmet="true" rel="shortcut icon" href="https://cdn.abcotvs.net/abcotv/assets/news/wpvi/images/logos/favicon.ico"/><link data-react-helmet="true" rel="manifest" href="//6abc.com/manifest.json"/><link data-react-helmet="true" rel="alternate" href="//6abc.com/feed/" title="6abc Philadelphia RSS" type="application/rss+xml"/><link data-react-helmet="true" rel="alternate" href="android-app://com.abclocal.wpvi.news/http/6abc.com/story/5515451"/><link data-react-helmet="true" rel="canonical" href="https://6abc.com/crime-fighters-who-killed-roger-david/5515451/"/><link data-react-helmet="true" rel="amphtml" href="https://6abc.com/amp/crime-fighters-who-killed-roger-david/5515451/"/><link data-react-helmet="true" rel="stylesheet" href="//d32rtoyz6r06ud.cloudfront.net/abcotv/ea673e8fb294-hotfix-dtcinews7.0/client/css/story.css"/>
            </head>
            <body>
                <div id="abcotv"><div id="fitt-analytics"><div class="wrapper"><section class="nav"><header class="feature-container wpvi"><a class="feature-action" href="/watch/" data-clink="**Filler**"><p>WATCH<span class="feature-watch-live"> <!-- -->LIVE</span></p></a><div class="feature-header-container"><div class="feature-search-overlay"></div><div class="feature-search-bar"><form class="form-search frame-search"><input type="text" class="search-bar-input" name="query" placeholder="Search 6abc.com" autoComplete="off"/><input type="submit" class="search-btn" value="Search"/></form></div><div class="feature-search-close"></div><div class="feature-header-left"><span class="feature-menu closed"><div class="menu-icon menu-closed"></div></span><a class="feature-logo" href="/" data-clink="**Filler**"><div class="sml-logo"></div><div class="lrg-logo"></div></a></div><div class="feature-header-right"><div class="feature-nav-local" style="max-width:undefinedpx"><div class="local-links"><span><a href="/philadelphia/">Philadelphia</a></span><span><a href="/pennsylvania/">Pennsylvania</a></span><span><a href="/new-jersey/">New Jersey</a></span><span><a href="/delaware/">Delaware</a></span></div></div><a class="feature-local-expand" href="#"></a><div class="feature-border feature-border-one"></div><div class="feature-weather-container weather-desktop"><a href="/weather/"><div class="feature-weather icon-weather_"></div><span class="feature-degrees"></span></a><div class="weather-text-container"><a href="/weather/" class="feature-weather-location"></a><a class="feature-weather-edit">EDIT</a></div></div><div class="feature-border feature-border-two"></div><div class="feature-ux-container"><a class="feature-logged-out login register">Log In</a><div class="feature-search-container"></div></div><div class="feature-border feature-border-three"></div></div></div></header><nav class=""><div class="nav-wrapper"><div class="nav-sections-main-local"><div class="nav-sections-links nav-sections-main"><div class="subnav-search-bar"><form class="form-search frame-search"><input type="text" class="search-bar-input" name="query" placeholder="Search 6abc.com" autoComplete="off"/><input type="submit" class="search-btn" value="Search"/></form></div><a class="subnav-main-btn" href="/watch/"><span class="subnav-watch"></span>Watch</a><a class="subnav-main-btn" href="/photos/"><span class="subnav-photos"></span>Photos</a></div><div class="nav-sections-links nav-sections-local subnav-local"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Local News<!-- --> <div class="expand-arrow-light"></div></a><div><span><a href="/philadelphia/">Philadelphia</a></span><span><a href="/pennsylvania/">Pennsylvania</a></span><span><a href="/new-jersey/">New Jersey</a></span><span><a href="/delaware/">Delaware</a></span></div></div></div></div><div class="nav-sections-links nav-sections-categories subnav-categories"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Categories<!-- --> <div class="expand-arrow-light"></div></a><div class="nav-sections-categories-1"><span><a href="/weather/">Weather</a></span><span><a href="/traffic/">Traffic</a></span><span><a href="/investigation/">Investigation</a></span><span><a href="https://6abc.com/troubleshooters/">Troubleshooters</a></span><span><a href="/consumer/">Consumer</a></span><span><a href="/healthcheck/">Healthcheck</a></span><span><a href="https://6abc.com/todaystip/">Today&#x27;s Tips</a></span><span><a href="https://6abc.com/tag/art-of-aging/">Art of Aging</a></span></div><div class="nav-sections-categories-2"><span><a href="/weather/">Weather</a></span><span><a href="/us-world/">U.S. &amp; World</a></span><span><a href="/politics/">Politics</a></span><span><a href="/entertainment/">Entertainment</a></span><span><a href="https://6abc.com/localish/">Localish</a></span><span><a href="/sports/">Sports</a></span><span><a href="https://6abc.com/lovesthearts/">6abc Loves the Arts</a></span></div></div></div><div class="nav-sections-community-shows nav-sections-station-info"><div class="nav-sections-links nav-sections-community subnav-community"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">Station Info<!-- --> <div class="expand-arrow-light"></div></a><div><span><a href="/about/">About 6abc/Contact Us!</a></span><span><a href="/about/newsteam/">Action News Biographies</a></span><span><a href="/promotions/">6abc Contests &amp; Promotions</a></span><span><a href="/tvlistings/">TV Listings</a></span><span><a href="/jobs/">Jobs &amp; Internships at 6abc</a></span><span><a href="/community/">Community</a></span></div></div></div></div><div class="nav-sections-community-shows"><div class="nav-sections-links nav-sections-shows subnav-shows"><div class="nav-sections-header"><a class="nav-section-name" data-clink="**Filler**">shows<!-- --> <div class="expand-arrow-light"></div></a><div><span><a href="/live/">Watch Action News Online</a></span><span><a href="/fyi/">FYI Philly</a></span><span><a href="https://6abc.com/InsideStory/">Inside Story</a></span><span><a href="https://6abc.com/proud/">Philly Proud</a></span><span><a href="https://6abc.com/blackhistory/">Visions</a></span><span><a href="https://6abc.com/Bestoftheclass/">Best of the Class</a></span></div></div></div></div><div class="nav-promos-follow"><div class="frame-social nav-social"><div class="frame-social-action">Follow Us:</div><div class="frame-social-icons"><a class="follow-btn follow-btn--facebook" href="https://www.facebook.com/6abc.ActionNews" target="_self"></a><a class="follow-btn follow-btn--instagram" href="https://www.instagram.com/6abcactionnews/" target="_self"></a><a class="follow-btn follow-btn--twitter" href="https://twitter.com/6abc" target="_self"></a><a class="follow-btn follow-btn--email" href="/newsletters" target="_self"></a></div></div></div></div></nav><div class="profile-drop-down"><div class="profile-name">Welcome, </div><div class="profile-edit">Your Account</div><div class="profile-logout">Log Out</div></div></section><main role="main" class="story"><div data-box-type="fitt-adbox-leaderboard1"><div class="Ad ad-slot" data-slot-type="leaderboard1" data-slot-kvps="pos=leaderboard1"></div></div><div class="content"><div class="side-left"><div class="StickyContainer" data-sticky-parent="true"><div class="" data-sticky="true"><div class="social-icons left-outer"><ul class="social"><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2F6abc.com%2Fcrime-fighters-who-killed-roger-david%2F5515451%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/&amp;text=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;via=6abc" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;body=A%20man%20leaving%20a%20club%20in%20West%20Philadelphia%20is%20shot%20and%20left%20for%20dead.%20%20Now%20his%20cousin%20traveled%20from%20North%20Carolina%20to%20plea%20for%20help%20in%20finding%20his%20killer.%20-%20https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/"><span class="text-callout">Email</span></a></li></ul></div></div></div></div><div class="main-wide main-left"><section class="lead-story inner post"><h1 class="headline">Crime Fighters: Who killed Roger David?</h1><div class="social-icons horizontal"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2F6abc.com%2Fcrime-fighters-who-killed-roger-david%2F5515451%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/&amp;text=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;via=6abc" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;body=A%20man%20leaving%20a%20club%20in%20West%20Philadelphia%20is%20shot%20and%20left%20for%20dead.%20%20Now%20his%20cousin%20traveled%20from%20North%20Carolina%20to%20plea%20for%20help%20in%20finding%20his%20killer.%20-%20https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/"><span class="text-callout">Email</span></a></li></ul></div><div class="top-media headline-list-item type-video"><div class="featured-media video type-videoClip"><div class="video-schema" itemProp="video" itemscope="" itemType="http://schema.org/VideoObject"><meta itemProp="name" content="Crime Fighters: Who killed Roger David?"/><meta itemProp="description" content="-"/><meta itemProp="thumbnailUrl" content="https://cdn.abcotvs.com/dip/images/5522984_090719-wpvi-crime-fighters-10pm-video-vid.jpg"/><meta itemProp="contentURL" content="https://content.uplynk.com/ext/10b98e7c615f43a98b180d51797e74aa/090719-wpvi-crime-fighters-10pm-video-vid.m3u8?ad._v=2&amp;ad=wpvi_video&amp;ad.preroll=&amp;ad.fill_slate=1&amp;ad.ametr=1"/><meta itemProp="uploadDate" content="2019-09-08T03:00:37Z"/></div></div></div></section><div class="story-body-wrapper post"><div class="mini-side-left"><div class="StickyContainer" data-sticky-parent="true"><div class="" data-sticky="true"><div class="social-icons left-inner"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2F6abc.com%2Fcrime-fighters-who-killed-roger-david%2F5515451%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/&amp;text=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;via=6abc" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;body=A%20man%20leaving%20a%20club%20in%20West%20Philadelphia%20is%20shot%20and%20left%20for%20dead.%20%20Now%20his%20cousin%20traveled%20from%20North%20Carolina%20to%20plea%20for%20help%20in%20finding%20his%20killer.%20-%20https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/"><span class="text-callout">Email</span></a></li></ul></div></div></div></div><div class="story-body-container"><section class="story-body inner"><div class="originBylineContainer"><div class="global-caption wpvi image-caption byline"><div class="origin-logo wpvi origin-image byline"><span class="wpvi byline">WPVI</span></div></div><div class="wpvi byline">By <!-- -->Heather Grubola</div></div><time class="meta lastmodified"> </time><div class="body-text">PHILADELPHIA (WPVI) -- A man leaving a club in West Philadelphia was shot and left for dead and his cousin traveled from North Carolina to plea for help in finding his killer.<br><br>"He was the most loving person that you can ever come across," described Ebony Thomas.<br><div class="adRectangle-pos-small-inline" data-set="adAppend"></div><br>Thomas said she was closer to her cousin, Roger David, than her own brothers and sisters.<br><br>"I taught him how to ride a bike.  I taught him how to play cards.  I taught him like everything that he knew growing up," she said.<br><br>She said the 29-year-old was never in trouble and what happened early Monday morning on March 31 shocked her.<br><br>"She told me he got shot in the back of his head after leaving the club," she said.<br><br>At 1:44 a.m. police were called to the area of 41st and Girard Avenue in West Philadelphia for reports of a person with a gun.<br><div class="adRectangle-pos-small-inline" data-set="adAppend"></div><br>That's where they found David and another man both suffering from gunshot wounds.  David died at the hospital.  The other man was admitted in fair condition.<br><br>"The chaos that's happening right now needs to stop.  You killing someone for what?  What do you get out of killing someone?  What do you get out of taking someone's life?" Thomas asked.<br><br>The <a href="http://www.crimecommission.org/" target="_blank">Citizens Crime Commission</a> is administering a $5,000 dollar reward and the City of Philadelphia is offering up to $20,000 in reward money for information that leads to the arrest and conviction of the person responsible.  All you have to do is call 215-546-TIPS.  All calls will remain anonymous.<br><br>"What I need is for us to come together to solve this you know because I can't do it on my own," she said. <div class="report-typo">
            <a target="_blank" rel="nofollow" href="/extras/reporttypo?url=https://6abc.com/crime-fighters-who-killed-roger-david/5515451/">Report a correction or typo</a>
        </div></div><div class="taxonomy"><div class="story-taxonomy"><strong>Related topics:</strong><br/><a class="button" href="/tag/philadelphia-news/">philadelphia news</a><a class="button" href="/tag/crime-fighters/">crime fighters</a></div></div><div class="social-icons horizontal"><ul class="social"><li class="share-text">Share:</li><li class="facebook"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2F6abc.com%2Fcrime-fighters-who-killed-roger-david%2F5515451%2F" target="_blank"><span class="text-callout">Share</span></a></li><li class="twitter"><a href="http://twitter.com/intent/tweet?url=https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/&amp;text=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;via=6abc" target="_blank"><span class="text-callout">Tweet</span></a></li><li class="email"><a href="mailto:?subject=Crime%20Fighters%3A%20Who%20killed%20Roger%20David%3F&amp;body=A%20man%20leaving%20a%20club%20in%20West%20Philadelphia%20is%20shot%20and%20left%20for%20dead.%20%20Now%20his%20cousin%20traveled%20from%20North%20Carolina%20to%20plea%20for%20help%20in%20finding%20his%20killer.%20-%20https%3A//6abc.com/crime-fighters-who-killed-roger-david/5515451/"><span class="text-callout">Email</span></a></li></ul></div><div class="meta">Copyright © 2019 WPVI-TV. All Rights Reserved.</div></section><div class="outbrainArticle"><section id="outbrain-youmightlike" class="inner"><div class="sponsored-content outbrain-vertical"><div class="sponsored-headlines pa4 relative outbrain-wrapper w-100"><div class="OUTBRAIN" data-widget-id="AR_2" data-src="https://6abc.com/crime-fighters-who-killed-roger-david/5515451/" data-ob-template="abclocal"></div></div></div></section><section id="outbrain-morefrom" class="inner"><div class="sponsored-content outbrain-vertical"><div class="sponsored-headlines pa4 relative outbrain-wrapper w-100"><div class="OUTBRAIN" data-widget-id="AR_1" data-src="https://6abc.com/crime-fighters-who-killed-roger-david/5515451/" data-ob-template="abclocal"></div></div></div></section></div></div></div><div class="side-wide-inner" data-set="right-sidebar-content"></div></div><div class="side-wide side-right" data-set="right-sidebar-content"><div class="side1"><div data-box-type="fitt-adbox-halfpage"><div class="Ad adRectangle-pos-medium ad-slot" data-slot-type="halfpage" data-slot-kvps="pos=halfpage"></div></div><section id="outbrain-sidebar" class="inner outbrainSidebarTwoCol"><div class="sponsored-content outbrain-vertical"><div class="sponsored-headlines pa4 relative outbrain-wrapper w-100"><div class="OUTBRAIN" data-widget-id="SB_1" data-src="https://6abc.com/crime-fighters-who-killed-roger-david/5515451/" data-ob-template="abclocal"></div></div></div></section><section class="cnnvan inner"><div class="section-header"><div>More Videos</div> </div><div id="vembaModule" data-vemba-zone="548734" data-category="Crime/Justice"></div><div class="meta text-center">From CNN Newsource affiliates</div></section><section><div class="hl-loader inner" id="story-page" data-fallback="topic two-col headlines-list" data-link="https://6abc.com/crime-fighters-who-killed-roger-david/5515451/"></div></section><section class="top-stories headlines-list inner"><div class="section-header"><div>TOP STORIES</div> </div><div class="top-stories-expanded"><div class="headlines-images"><div class="headline-list-item has-image" data-media="video"><a target="_self" href="/14-year-old-shot-in-the-head-in-chester-pa/5522631/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/5522958_090719-wpvi-chester-shooting-10pm-video-vid.jpg" data-imgalt="14-year-old shot in the head in Chester, Pa. Annie McCormick reports during Action News at 10pm on September 7, 2019." data-topic="crime-safety" data-dynamic="https://cdn.abcotvs.com/dip/images/5522958_090719-wpvi-chester-shooting-10pm-video-vid.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/5522958_090719-wpvi-chester-shooting-10pm-video-vid.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">14-year-old shot in the head in Chester, Pa.</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 has-image" data-media="video"><a target="_self" href="/4-month-old-boy-found-dead-at-phila-home-mother-in-custody/5522416/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/5522967_090719-wpvi-north-philadelphia-baby-death-10pm-video-vid.jpg" data-imgalt="4-month-old boy found dead at Phila. home, mother in custody. Katie Katro reports during Action News at 10pm on September 7, 2019." data-topic="crime-safety" data-dynamic="https://cdn.abcotvs.com/dip/images/5522967_090719-wpvi-north-philadelphia-baby-death-10pm-video-vid.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/5522967_090719-wpvi-north-philadelphia-baby-death-10pm-video-vid.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">4-month-old boy found dead at Phila. home, mother in custody</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 has-image" data-media="video"><a target="_self" href="/mt-laurel-woman-23-charged-with-stabbing-her-mother-to-death/5522523/"><div class="image dynamic-loaded" data-imgsrc="https://cdn.abcotvs.com/dip/images/5522521_090719marisarivera.jpg" data-imgalt="23-year-old Mount Laurel woman charged with stabbing her mother to death. Watch this update from September 7, 2019." data-topic="crime-safety" data-dynamic="https://cdn.abcotvs.com/dip/images/5522521_090719marisarivera.jpg"><img class="dynamic-img" src="https://cdn.abcotvs.com/dip/images/5522521_090719marisarivera.jpg?w=630&amp;r=16%3A9"/></div><div class="headline">Mt. Laurel woman, 23, charged with stabbing her mother to death</div><time class="meta lastmodified"> </time></a></div></div><div class="top-stories-more headlines-noimages single-line"><div class="headline-list-item no-image" data-media="post"><a target="_self" href="/report-day-care-where-infant-killed-recently-passed-inspection/5522545/"><div class="headline">Report: Day care where infant killed recently passed inspection</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 no-image" data-media="post"><a target="_self" href="/weather/accuweather-seasonable-sunday/49644/"><div class="headline">AccuWeather: Seasonable Sunday</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 no-image" data-media="post"><a target="_self" href="/politics/trump-calls-off-secret-meeting-with-taliban-afghan-leaders/5522912/"><div class="headline">Trump calls off secret meeting with Taliban, Afghan leaders</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-3 no-image" data-media="post"><a target="_self" href="/sports/antonio-brown-reaches-agreement-with-patriots-after-release-from-raiders-espn/5522663/"><div class="headline">Antonio Brown reaches agreement with Patriots after release from Raiders: ESPN</div><time class="meta lastmodified"> </time></a></div></div></div><a class="show-button-more button button-block">Show More <div class="expand-arrow"></div></a><div class="top-stories-collapsed"><div class="top-stories-more headlines-noimages single-line"><div class="headline-list-item no-image" data-media="post"><a target="_self" href="/traffic/driver-killed-after-crashing-into-tree-in-ne-philadelphia/5522053/"><div class="headline">Driver killed after crashing into tree in NE Philadelphia</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-1 no-image" data-media="post"><a target="_self" href="/man-involved-in-love-triangle-murder-suicide-case-speaks-out/5520171/"><div class="headline">Man involved in love triangle murder-suicide case speaks out</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-2 no-image" data-media="post"><a target="_self" href="/sports/fmr-cardinals-outfielder-chris-duncan-dies-of-brain-cancer-at-38/5522094/"><div class="headline">Fmr. Cardinals outfielder Chris Duncan dies of brain cancer at 38</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-3 no-image" data-media="post"><a target="_self" href="/sports/eagles-built-a-room-in-the-linc-for-fans-with-sensory-needs/5522121/"><div class="headline">Eagles built a room in the Linc for fans with sensory needs</div><time class="meta lastmodified"> </time></a></div><div class="headline-list-item item-4 no-image" data-media="post"><a target="_self" href="/man-dead-after-kensington-apartment-fire/5522414/"><div class="headline">Man dead after Kensington apartment fire</div><time class="meta lastmodified"> </time></a></div></div><a class="button button-block" href="/news/">More <!-- -->TOP STORIES News<div class="arrow-blue arrow-pos-right"></div></a></div></section></div></div><div class="clear"></div></div></main><footer class="footer" role="contentinfo"><div class="footer-searchsocial"><div class="footer-brand desktop"><div class="footer-brand-logo" lpos="footer_logo"><a href="/"><img src="https://cdn.abcotvs.net/abcotv/static/wpvi/logos/wpvi_logo_2x.png" alt="6abc Philadelphia"/></a></div></div><section class="footer-smallnav"><ul><li><a href="/">Home</a></li><li><a href="/weather/">AccuWeather</a></li><li><a href="/traffic/">Traffic</a></li><li class=""><a class="footer-smallnav-header">Local News<div class="expand-arrow-light"></div></a><ul><a href="/philadelphia/">Philadelphia</a><a href="/pennsylvania/">Pennsylvania</a><a href="/new-jersey/">New Jersey</a><a href="/delaware/">Delaware</a></ul></li><li class=""><a class="footer-smallnav-header">Categories<div class="expand-arrow-light"></div></a><ul><a href="/watch/">Watch</a><a href="/photos/">Photos</a><a href="/investigation/">Investigation</a><a href="https://6abc.com/troubleshooters/">Troubleshooters</a><a href="/consumer/">Consumer</a><a href="/healthcheck/">Healthcheck</a><a href="https://6abc.com/todaystip/">Today&#x27;s Tips</a><a href="https://6abc.com/tag/art-of-aging/">Art of Aging</a></ul></li><li class=""><a class="footer-smallnav-header">Station Info<div class="expand-arrow-light"></div></a><ul><a href="/about/">About 6abc/Contact Us!</a><a href="/about/newsteam/">Action News Biographies</a><a href="/promotions/">6abc Contests &amp; Promotions</a><a href="/tvlistings/">TV Listings</a><a href="/jobs/">Jobs &amp; Internships at 6abc</a><a href="/community/">Community</a></ul></li><li class=""><a class="footer-smallnav-header">Shows<div class="expand-arrow-light"></div></a><ul><a href="/live/">Watch Action News Online</a><a href="/fyi/">FYI Philly</a><a href="https://6abc.com/InsideStory/">Inside Story</a><a href="https://6abc.com/proud/">Philly Proud</a><a href="https://6abc.com/blackhistory/">Visions</a><a href="https://6abc.com/Bestoftheclass/">Best of the Class</a></ul></li><li><a href="/apps/">Apps</a></li></ul></section><div class="footer-brand mobile"><div class="footer-brand-logo" lpos="footer_logo"><a href="/"><img src="https://cdn.abcotvs.net/abcotv/static/wpvi/logos/wpvi_logo_2x.png" alt="6abc Philadelphia"/></a></div></div><div class="clear"></div><div class="frame-social"><div class="frame-social-action">Follow Us:</div><div class="frame-social-icons"><a class="follow-btn follow-btn--facebook" href="https://www.facebook.com/6abc.ActionNews" target="_self"></a><a class="follow-btn follow-btn--instagram" href="https://www.instagram.com/6abcactionnews/" target="_self"></a><a class="follow-btn follow-btn--twitter" href="https://twitter.com/6abc" target="_self"></a><a class="follow-btn follow-btn--email" href="/newsletters" target="_self"></a></div></div></div><div class="footer-sections"><div class="footer-sections-col1"><div class="footer-sections-group"><a href="/">Home</a><a href="/weather/">Weather</a><a href="/traffic/">Traffic</a><a href="/watch/">Watch</a><a href="/photos/">Photos</a><a href="/apps/">Apps</a></div><div class="footer-sections-group"><a href="/philadelphia/">Philadelphia</a><a href="/pennsylvania/">Pennsylvania</a><a href="/new-jersey/">New Jersey</a><a href="/delaware/">Delaware</a></div></div><div class="footer-sections-col2"><div class="footer-sections-group"><a href="/investigation/">Investigation</a><a href="https://6abc.com/troubleshooters/">Troubleshooters</a><a href="/consumer/">Consumer</a><a href="/healthcheck/">Healthcheck</a><a href="https://6abc.com/todaystip/">Today&#x27;s Tips</a><a href="https://6abc.com/tag/art-of-aging/">Art of Aging</a></div><div class="footer-sections-group"><a href="/about/">About 6abc/Contact Us!</a><a href="/about/newsteam/">Action News Biographies</a><a href="/promotions/">6abc Contests &amp; Promotions</a><a href="/tvlistings/">TV Listings</a><a href="/jobs/">Jobs &amp; Internships at 6abc</a><a href="/community/">Community</a></div></div></div><div class="footer-legal"><div class="footer-legal-links" lpos="footer_legal"><ul class="footer-legal-links-mobile"><li><a href="https://disneyprivacycenter.com/">Privacy Policy</a></li><li><a href="https://disneyprivacycenter.com/kids-privacy-policy/english/">Children&#x27;s Privacy Policy</a></li><li><a href="https://disneyprivacycenter.com/notice-to-california-residents/">Your California Privacy Rights</a></li><li><a href="http://disneytermsofuse.com/">Terms of Use</a></li><li><a href="http://preferences.truste.com/2.0/?type=abc&amp;affiliateId=115">Interest-Based Ads</a></li><li><a href="https://publicfiles.fcc.gov/tv-profile/wpvi-tv">Public Inspection File</a></li></ul><div class="footer-legal-links-col1"><a href="https://disneyprivacycenter.com/" target="_blank">Privacy Policy</a><a href="https://disneyprivacycenter.com/kids-privacy-policy/english/" target="_blank">Children&#x27;s Privacy Policy</a><a href="https://disneyprivacycenter.com/notice-to-california-residents/" target="_blank">Your California Privacy Rights</a></div><div class="footer-legal-links-col2"><a href="http://disneytermsofuse.com/" target="_blank">Terms of Use</a><a href="http://preferences.truste.com/2.0/?type=abc&amp;affiliateId=115" target="_blank">Interest-Based Ads</a><a href="https://publicfiles.fcc.gov/tv-profile/wpvi-tv" target="_blank">Public Inspection File</a></div><div class="clear"></div></div><div class="footer-legal-copyright">Copyright © <!-- -->2019<!-- --> <!-- -->ABC, Inc., WPVI-TV Philadelphia.<!-- --> All Rights Reserved.</div></div><div class="clear"></div></footer><div><script type='text/javascript'>
            (function(){var g=function(e,h,f,g){
            this.get=function(a){for(var a=a+"=",c=document.cookie.split(";"),b=0,e=c.length;b<e;b++){for(var d=c[b];" "==d.charAt(0);)d=d.substring(1,d.length);if(0==d.indexOf(a))return d.substring(a.length,d.length)}return null};
            this.set=function(a,c){var b="",b=new Date;b.setTime(b.getTime()+6048E5);b="; expires="+b.toGMTString();document.cookie=a+"="+c+b+"; path=/; "};
            this.check=function(){var a=this.get(f);if(a)a=a.split(":");else if(100!=e)"v"==h&&(e=Math.random()>=e/100?0:100),a=[h,e,0],this.set(f,a.join(":"));else return!0;var c=a[1];if(100==c)return!0;switch(a[0]){case "v":return!1;case "r":return c=a[2]%Math.floor(100/c),a[2]++,this.set(f,a.join(":")),!c}return!0};
            this.go=function(){if(this.check()){var a=document.createElement("script");a.type="text/javascript";a.src=g+ "&t=" + (new Date()).getTime();document.body&&document.body.appendChild(a)}};
            this.start=function(){var a=this;window.addEventListener?window.addEventListener("load",function(){a.go()},!1):window.attachEvent&&window.attachEvent("onload",function(){a.go()})}};
            try{(new g(100,"r","QSI_S_ZN_5hSLIyrLhlJ7ndr","//zn5hsliyrlhlj7ndr-abcotv.siteintercept.qualtrics.com/WRSiteInterceptEngine/?Q_ZID=ZN_5hSLIyrLhlJ7ndr&Q_LOC="+encodeURIComponent(window.location.href))).start()}catch(i){}})();
        </script>
        <div id="ZN_5hSLIyrLhlJ7ndr"></div></div><div>
<!-- Facebook Pixel Code -->
<script>
 !function(f,b,e,v,n,t,s)
 {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
 n.callMethod.apply(n,arguments):n.queue.push(arguments)};
 if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
 n.queue=[];t=b.createElement(e);t.async=!0;
 t.src=v;s=b.getElementsByTagName(e)[0];
 s.parentNode.insertBefore(t,s)}(window,document,'script',
 'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '679006512549059');
 fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1"
  src="https://www.facebook.com/tr?id=679006512549059&ev=PageView&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code --></div><div data-box-type="fitt-adbox-adhesion"><div class="Ad ad-slot" data-slot-type="adhesion" data-slot-kvps="pos=adhesion"></div></div><div data-box-type="fitt-adbox-interstitial"><div class="Ad ad-slot" data-slot-type="interstitial" data-slot-kvps="pos=interstitial"></div></div><div></div></div></div></div>
                <script type='text/javascript' >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</script>
                <script type='text/javascript' src="//d32rtoyz6r06ud.cloudfront.net/abcotv/ea673e8fb294-hotfix-dtcinews7.0/client/abcotv.js"></script><script type='text/javascript' src="//d32rtoyz6r06ud.cloudfront.net/abcotv/ea673e8fb294-hotfix-dtcinews7.0/client/story.js"></script>
            </body>
        </html>
    